Creates a new flexible duct into the document, using a point array and flexible duct type.
Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document.
- systemTypeId
- Type: Autodesk.Revit.DB ElementId
The id of the HVAC system type.
- ductTypeId
- Type: Autodesk.Revit.DB ElementId
The id of the flexible duct.
- levelId
- Type: Autodesk.Revit.DB ElementId
The level id for the flexible duct.
- points
- Type: System.Collections.Generic IList XYZ
The point array indicating the path of the flexible duct, including the end point.
Return Value
If creation was successful then a new flexible duct is returned, otherwise an exception with failure information will be thrown.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The systemTypeId is not valid HVAC system type. -or- The type ductTypeId is not valid flexible duct type. -or- The level id levelId is not valid. -or- The valid number of points is less than two. In order to create a flex curve, at least two points are required. Note the duplicate points don't take into account. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping. |