Deletes the specified AreaReinforcement, and converts its RebarInSystem elements to equivalent Rebar elements.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- doc
- Type: Autodesk.Revit.DB Document
The document.
- system
- Type: Autodesk.Revit.DB.Structure AreaReinforcement
An AreaReinforcement element in the document.
Return Value
The ids of the newly created Rebar elements.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The document doc does not contain the element system -or- system does not host Rebar. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions DisabledDisciplineException | None of the following disciplines is enabled: Structural. |