Sets the alignment method for a given selector and direction.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- selector
- Type: Autodesk.Revit.DB.Structure AnalyticalElementSelector
End of the analytical model.
- direction
- Type: Autodesk.Revit.DB.Structure AnalyticalDirection
Direction of the analytical model.
- method
- Type: Autodesk.Revit.DB.Structure AnalyticalAlignmentMethod
The alignment method at a given end.
Remarks
Applicable for analytical models of linear elements (beams, braces, columns).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | direction is invalid for analytical model -or- method is in valid for analytical model |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |