OnRestoreDefaultsAction Property


The restore defaults handler.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013

Syntax

C#
public TabbedDialogAction OnRestoreDefaultsAction { get; set; }
Visual Basic
Public Property OnRestoreDefaultsAction As TabbedDialogAction
	Get
	Set
Visual C++
public:
property TabbedDialogAction^ OnRestoreDefaultsAction {
	TabbedDialogAction^ get ();
	void set (TabbedDialogAction^ value);
}

Remarks

This handler will be invoked when the "Restore Defaults" button in Revit options dialog is clicked and the handler should apply only to options set on this page. There is no "Restore Defaults" button in Revit options dialog if this property was set to a null reference ( Nothing in Visual Basic) .

See Also