Opens an IFC document from disk using default options.
Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- fileName
- Type: System String
The IFC file to be opened.
Return Value
The newly created document containing the IFC file.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | If 'fileName' is an empty string. |
Autodesk.Revit.Exceptions ArgumentNullException | If a null reference ( Nothing in Visual Basic) is passed as 'fileName' -or- A non-optional argument was NULL |
Autodesk.Revit.Exceptions FileArgumentNotFoundException | If the file specified by 'fileName' cannot be found. |
Autodesk.Revit.Exceptions InvalidOperationException | If Revit is missing document templates or if the file cannot be opened. |