Extension Property


The extension scale value. Controls the magnitude of line's extension. Values between 0 and 10.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2015

Syntax

C#
public int Extension { get; set; }
Visual Basic
Public Property Extension As Integer
	Get
	Set
Visual C++
public:
property int Extension {
	int get ();
	void set (int value);
}

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentOutOfRangeException When setting this property: The extension value is not valid. The valid range is 0 to 10.

See Also