PipeConnectionType Class


A pipe connection type in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
[ObsoleteAttribute("This class is obsolete in Revit 2014, as connection types are no longer supported.")]
public class PipeConnectionType : ElementType
Visual Basic
<ObsoleteAttribute("This class is obsolete in Revit 2014, as connection types are no longer supported.")> _
Public Class PipeConnectionType _
	Inherits ElementType
Visual C++
[ObsoleteAttribute(L"This class is obsolete in Revit 2014, as connection types are no longer supported.")]
public ref class PipeConnectionType : public ElementType

Remarks

The pipe connection type is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

See Also