SetStyle Method


Sets the associated handle to an IfcTypeProduct for the type.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012

Syntax

C#
public void SetStyle(
	IFCAnyHandle typeProductHandle
)
Visual Basic
Public Sub SetStyle ( _
	typeProductHandle As IFCAnyHandle _
)
Visual C++
public:
void SetStyle(
	IFCAnyHandle^ typeProductHandle
)

Parameters

typeProductHandle
Type: Autodesk.Revit.DB.IFC IFCAnyHandle
The handle.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also