Indicates if the input direction is valid for Analytical Model projection.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- direction
- Type: Autodesk.Revit.DB.Structure AnalyticalDirection
Direction in which the Analytical Model may be projected.
Return Value
True if AnalyticalDirection is valid for Element, false otherwise.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |