SelElementSet Class


This class contains the current user selection of elements within the project.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
[ObsoleteAttribute("This class is deprecated in Revit 2015. Use Selection.SetElementIds() and Selection.GetElementIds() instead.")]
public class SelElementSet : ElementSet
Visual Basic
<ObsoleteAttribute("This class is deprecated in Revit 2015. Use Selection.SetElementIds() and Selection.GetElementIds() instead.")> _
Public Class SelElementSet _
	Inherits ElementSet
Visual C++
[ObsoleteAttribute(L"This class is deprecated in Revit 2015. Use Selection.SetElementIds() and Selection.GetElementIds() instead.")]
public ref class SelElementSet : public ElementSet

Remarks

Add or Remove elements from the selected element set. The elements in the set will be highlighted as selected elements in the UI.

Inheritance Hierarchy

See Also