Returns the vectors describing the face at the specified point.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- point
- Type: Autodesk.Revit.DB UV
The parameters to be evaluated, in natural parameterization of the face.
Return Value
The transformation containing tangent vectors and a normal vector.Remarks
The following is the meaning of the transformation members:
- Origin is the point on the face (equivalent to Evaluate);
- BasisX is the tangent vector along the U coordinate (partial derivative with respect to U).
- BasisY is the tangent vector along the V coordinate (partial derivative with respect to V).
- BasisZ is the "surface normal" vector. This is not necessarily the normal vector pointing out of the solid that contains the face, to get that value use ComputeNormal(UV) .