InitialState Property


The initial position of the docking pane.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014

Syntax

C#
public DockablePaneState InitialState { get; set; }
Visual Basic
Public Property InitialState As DockablePaneState
	Get
	Set
Visual C++
public:
property DockablePaneState^ InitialState {
	DockablePaneState^ get ();
	void set (DockablePaneState^ value);
}

Remarks

This position will be used for the first Revit session in which the pane is registered; afterwards, the user is free to reposition the pane, and the user's saved position will be remembered in future sessions.

See Also