ConvertModelPathToUserVisiblePath Method


Gets a string version of the path of a given ModelPath.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012

Syntax

C#
public static string ConvertModelPathToUserVisiblePath(
	ModelPath path
)
Visual Basic
Public Shared Function ConvertModelPathToUserVisiblePath ( _
	path As ModelPath _
) As String
Visual C++
public:
static String^ ConvertModelPathToUserVisiblePath(
	ModelPath^ path
)

Parameters

path
Type: Autodesk.Revit.DB ModelPath
A ModelPath representing a file path or a server path.

Return Value

The path in string form

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also