Creates a new geometric plane object based on a normal vector and an origin.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- norm
- Type: Autodesk.Revit.DB XYZ
Z vector of the plane coordinate system.
- origin
- Type: Autodesk.Revit.DB XYZ
Origin of the plane coordinate system.
Return Value
A new plane object.Examples

// Create a geometry plane in Revit application
XYZ normal = XYZ.BasisZ; // use basis of the z-axis (0,0,1) for normal vector
XYZ origin = XYZ.Zero; // origin is (0,0,0)
Plane geomPlane = application.Create.NewPlane(normal, origin);

' Create a geometry plane in Revit application
Dim normal As XYZ = XYZ.BasisZ
' use basis of the z-axis (0,0,1) for normal vector
Dim origin As XYZ = XYZ.Zero
' origin is (0,0,0)
Dim geomPlane As Plane = application.Create.NewPlane(normal, origin)