SetRefPoint Method


Sets the 3D point in the document where the imported instance will be inserted. If not explicitly set, the instance will be inserted at the document origin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013

Syntax

C#
public void SetRefPoint(
	XYZ point
)
Visual Basic
Public Sub SetRefPoint ( _
	point As XYZ _
)
Visual C++
public:
void SetRefPoint(
	XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.DB XYZ

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also