An enumerated type containing possible orientation types for Adaptive Points.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Members
Member name | Description |
---|---|
HostReferenceStrictly | Strictly follows the orientation of the host reference point on placement. |
HostReferenceAutoFlip | Follows the orientation of the host reference point on placement but calculates and aligns its flip sense with FamilyInstace's coordinate system. |
PlacementVertical | Point is oriented vertically on placement. |
PlacementOrthogonal | Point is oriented orthogonally on placement. |
FamilyVertical | Point is oriented vertically on placement in the FamilyInstace's coordinate system. |
FamilyOrthogonal | Point is oriented orthogonally on placement in the FamilyInstace's coordinate system. This value is optimal for performance of families. |