NewSlab Method


Creates a slab within the project with the given horizontal profile using the default floor style.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public Floor NewSlab(
	CurveArray profile,
	Level level,
	Line slopedArrow,
	double slope,
	bool isStructural
)
Visual Basic
Public Function NewSlab ( _
	profile As CurveArray, _
	level As Level, _
	slopedArrow As Line, _
	slope As Double, _
	isStructural As Boolean _
) As Floor
Visual C++
public:
Floor^ NewSlab(
	CurveArray^ profile, 
	Level^ level, 
	Line^ slopedArrow, 
	double slope, 
	bool isStructural
)

Parameters

profile
Type: Autodesk.Revit.DB CurveArray
An array of planar lines and arcs that represent the horizontal profile of the slab.
level
Type: Autodesk.Revit.DB Level
The level on which the slab is to be placed.
slopedArrow
Type: Autodesk.Revit.DB Line
A line use to control the sloped angle of the slab. It should be in the same face with profile.
slope
Type: System Double
The slope.
isStructural
Type: System Boolean
If set, specifies that the floor is structural in nature.

Return Value

If successful a new floor object within the project, otherwise a null reference ( Nothing in Visual Basic) .

Remarks

The curves of the profile must be contiguous and the Face formed by profile should be suitable to create slab.

See Also