Sets the analytical model projection to a preset value.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- selector
- Type: Autodesk.Revit.DB.Structure AnalyticalElementSelector
End of the analytical model.
- direction
- Type: Autodesk.Revit.DB.Structure AnalyticalDirection
Direction of the analytical model.
- projectionType
- Type: Autodesk.Revit.DB.Structure AnalyticalProjectionType
Preset value for Analytical Model projection.
Remarks
This should be used if setting the analytical model projection to something other than a Datum Plane.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | direction is invalid for analytical model -or- The analytical model does not provide projectionType for the selector or direction |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |