Set2DMapHandle Method


Sets the associated handle to a 2D IfcRepresentationMap for the type.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012

Syntax

C#
public void Set2DMapHandle(
	IFCAnyHandle representationMapHandle
)
Visual Basic
Public Sub Set2DMapHandle ( _
	representationMapHandle As IFCAnyHandle _
)
Visual C++
public:
void Set2DMapHandle(
	IFCAnyHandle^ representationMapHandle
)

Parameters

representationMapHandle
Type: Autodesk.Revit.DB.IFC IFCAnyHandle
The handle.

Remarks

Typically used only for Building Element Proxy elements (masses).

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also