PulldownButtonData Constructor


Constructs a new instance of PulldownButtonData.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public PulldownButtonData(
	string name,
	string text
)
Visual Basic
Public Sub New ( _
	name As String, _
	text As String _
)
Visual C++
public:
PulldownButtonData(
	String^ name, 
	String^ text
)

Parameters

name
Type: System String
The internal name of the new button.
text
Type: System String

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException Thrown when a null reference ( Nothing in Visual Basic) is passed for one or more arguments.
Autodesk.Revit.Exceptions ArgumentException Thrown when an empty string is passed for one or more arguments.

See Also