Phase Class


Represents a phase in the life of a building.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public class Phase : Element
Visual Basic
Public Class Phase _
	Inherits Element
Visual C++
public ref class Phase : public Element

Remarks

The lifetime of an element within a building can be controlled by using phases. Each element will have a construction phase but only those elements that have a finite lifetime will have a destruction phase. All the phases within a project can be retrieved from the Document object.

Inheritance Hierarchy

See Also