Remove the fixed direction from a segment.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- iSegment
- Type: System Int32
Index of the segment (0 to NumberOfSegments - 1).
Remarks
The segment's angle will be allowed to vary, with a range of 90 degrees. The segment must have at least two constraints.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | iSegment is not between 0 and NumberOfSegments. |