GetEnumerator Method


Returns an enumerator that iterates through the collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public virtual IEnumerator<KeyValuePair<ExportLineweightKey, ExportLineweightInfo>> GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator(Of KeyValuePair(Of ExportLineweightKey, ExportLineweightInfo))
Visual C++
public:
virtual IEnumerator<KeyValuePair<ExportLineweightKey^, ExportLineweightInfo^>>^ GetEnumerator()

Return Value

An IEnumerator( KeyValuePair(ExportLineweightKey^,ExportLineweightInfo^) ) object that can be used to iterate through key-value pairs in the collection.

Implements

IEnumerable T GetEnumerator

See Also