Autodesk.Revit.DB.IFC Namespace


Classes

Class Description
Public class ExporterIFC
The main class provided by Revit to allow implementation of IFC export.
Public class ExporterIFCRegistry Obsolete.
Application level singleton that stores registered IFC exporters.
Public class ExporterIFCUtils
A class that contains utilities needed to implement Revit's version of the IFC export client application.
Public class IFCAggregate
A collection of IFC handles or attributes.
Public class IFCAggregateIterator
A class used to iterate individual objects in an IFCAggregate.
Public class IFCAnyHandle
A handle representing an item in an IFC file.
Public class IFCConnectedWallData
A class that contains the IFC-specific information about how an element is joined to another element.
Public class IFCData
A specialized type of abstract data block that can represent any data type.
Public class IFCExtrusionCalculatorOptions
This class contains the options used to calculate extrusions from Revit geometry.
Public class IFCExtrusionCalculatorUtils
A utility class used to calculate extrusion data from Revit geometry for IFC export.
Public class IFCExtrusionCreationData
A utility object that is used to pass information related to extrusion creation.
Public class IFCExtrusionData
Represents the geometry of an extrusion (a solid body or opening) generated from Revit geometry.
Public class IFCFamilyInstanceExtrusionExportResults
This class represents the results of a geometric analysis of a family instance.
Public class IFCFile
Represents the IFC file which is being created during export.
Public class IFCFileModelOptions
This class contains options to create an IFC file model.
Public class IFCFileReadOptions
This class contains options to read an IFC file.
Public class IFCFileWriteOptions
This class contains options to write an IFC file.
Public class IFCGeometryInfo
A container class for Revit geometry extracted from an element.
Public class IFCImportOptions
IFC Import options.
Public class IFCLegacyStairOrRamp
The class contains the components of a legacy stair or ramp.
Public class IFCLevelInfo
Represents information about a particular level in the document.
Public class IFCOpeningData
A class that contains opening data including extrusion data, opening solids and opening element id.
Public class IFCProductWrapper
This class is used to ensure that elements and objects are associated with the current IfcProduct.
Public class IFCRange
Typically for IFC export, this represents the lower and upper elevations for split wall and column geometry.
Public class IFCTransaction
IFC transactions are context-like objects that guard any changes made to an IFC file.
Public class IFCTransformSetter
A state-based class that forces an extra transformation applied to objects being exported.
Public class IFCTypeInfo Obsolete.
An info class representing data about a given element type, typically used for Revit family types.
Public class ImporterIFC
The main class provided by Revit to allow implementation of IFC import.
Public class ImporterIFCUtils
A class that contains utilities needed to implement Revit's version of the IFC import client application.
Public class RoofComponents
A class that contains multiple roof slab infos of a roof.

Interfaces

Interface Description
Public interface IExporterIFC
The interface used to implement a custom IFC exporter.
Public interface IIFCImporterServer
Interface for external servers implementing IFC import.

Enumerations

Enumeration Description
Public enumeration IFCConnectedWallDataLocation
An enumerated type that represents the location where an element is connected to a wall.
Public enumeration IFCDataPrimitiveType
Used in operations to specify the primitive type of an IFCData.
Public enumeration IFCDoorStyleOperation Obsolete.
The types of door operations, as defined in IFC2x3. This relates to how the door opens.
Public enumeration IFCExtrusionAxes
Represents the possible axes to try when generating an extrusion using IFCCreateExtrusionData.
Public enumeration IFCExtrusionBasis
This enumerated type represents the possible bases for derivation of extrusion geometry.
Public enumeration IFCFileFormat
The IFC file format.
Public enumeration IFCImportAction
The action of the IFC import.
Public enumeration IFCImportIntent
The intent of the IFC import.
Public enumeration IFCLogical
A datatype can have values TRUE, FALSE or UNKNOWN.
Public enumeration IFCProjectLevelGUIDType
The type of the GUID to be retrieved from Revit.
Public enumeration IFCWindowStyleOperation Obsolete.
The types of window configurations, as defined in IFC2x3.