GetTypeList Method


Gets the multiple strings represent one IFC type name.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013

Syntax

C#
public IList<string> GetTypeList()
Visual Basic
Public Function GetTypeList As IList(Of String)
Visual C++
public:
IList<String^>^ GetTypeList()

Return Value

The strings.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions InvalidOperationException No type assigned or it is a simple type.

See Also