Creates a new parameter definition using name and type.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- name
- Type: System String
The name of the parameter definition to be created.
- type
- Type: Autodesk.Revit.DB ParameterType
The name of the parameter type for the new definition.
Return Value
If successful a reference to the new parameter definition is returned, otherwise a null reference ( Nothing in Visual Basic) .Remarks
This method only supports creation of new external defintions (shared parameters).