GetSweptProfile Method


Retrieves the swept profile information for Analytical Model.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011

Syntax

C#
public AnalyticalModelSweptProfile GetSweptProfile()
Visual Basic
Public Function GetSweptProfile As AnalyticalModelSweptProfile
Visual C++
public:
AnalyticalModelSweptProfile^ GetSweptProfile()

Return Value

The swept profile information for the Analytical Model.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions InapplicableDataException This AnalyticalModel does not support a swept profile representation.

See Also