An enumerated type listing available view types.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Members
Member name | Description |
---|---|
Undefined | Undefined/unspecified type of view. |
FloorPlan | Floor plan type of view. |
CeilingPlan | Reflected ceiling plan type of view. |
Elevation | Elevation type of view. |
ThreeD | 3-D type of view. |
Schedule | Schedule type of view. |
DrawingSheet | Drawing sheet type of view. |
ProjectBrowser | The project browser view. |
Report | Report type of view. |
DraftingView | Drafting type of view. |
Legend | Legend type of view. |
SystemBrowser | The MEP system browser view. |
EngineeringPlan | Structural plan or Engineering plan type of view. |
AreaPlan | Area plan type of view. |
Section | Cross section type of view. |
Detail | Detail type of view. |
CostReport | Cost Report view. |
LoadsReport | Loads Report view. |
PresureLossReport | Pressure Loss Report view. |
ColumnSchedule | Column Schedule type of view. |
PanelSchedule | Panel Schedule Report view. |
Walkthrough | Walk-Through type of 3D view. |
Rendering | Rendering type of view. |
Internal | Revit's internal type of view |