Indicates how the material of MassZone faces is determined.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Remarks
The material of the MassZone faced will be determined in the following ways based on the material type. MassZoneMaterialTypeMaterialBySurfaceType: Each MassZone face will use the material defined by the object style of the subcategory of the Element returned by getMassDataElementIdForZoneFaceReference(..). MassZoneMaterialTypeNormalMaterial: If the materialId is InvalidElementId, then the material defined by the object style of the MassZone subcategory will be used for all faces of the MassZone. MassZoneMaterialTypeNormalMaterial: If the materialId is the id of a Material element, that material id will be used for all faces of the MassZone.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | When setting this property: The material type does not fall within an appropriate range. |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration |