GetLocalCoordinateSystem Method


Gets the local coordinate system (LCS) for an analytical model element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011

Syntax

C#
public Transform GetLocalCoordinateSystem()
Visual Basic
Public Function GetLocalCoordinateSystem As Transform
Visual C++
public:
Transform^ GetLocalCoordinateSystem()

Return Value

Transformation matrix. Returns a null reference ( Nothing in Visual Basic) for curved beam and arc wall analytical model element. Origin is always (0, 0, 0).

Exceptions

Exception Condition
Autodesk.Revit.Exceptions InvalidOperationException Thrown when called on Isolated Foundation and Wall Foundation analytical model element. Those elements do not support local coordinate system.

See Also