Reference Property


Returns a stable reference to the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public Reference Reference { get; }
Visual Basic
Public ReadOnly Property Reference As Reference
	Get
Visual C++
public:
property Reference^ Reference {
	Reference^ get ();
}

Field Value

This value is set for curve geometry obtained from Revit elements. a null reference ( Nothing in Visual Basic) if the curve was created via parameters, copying, transform, or other operations.

See Also