NewGrid Method (Line)


Creates a new linear grid line.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public Grid NewGrid(
	Line line
)
Visual Basic
Public Function NewGrid ( _
	line As Line _
) As Grid
Visual C++
public:
Grid^ NewGrid(
	Line^ line
)

Parameters

line
Type: Autodesk.Revit.DB Line
A line object which represents the location of the grid line.

Return Value

The newly created grid line.

Remarks

The line should be on a horizontal plane.

Examples

Copy C#
// Create the geometry line which the grid locates
XYZ start = new XYZ(0, 0, 0);
XYZ end = new XYZ(30, 30, 0);
Line geomLine = Line.CreateBound(start, end);

// Create a grid using the geometry line
Grid lineGrid = document.Create.NewGrid(geomLine);

if (null == lineGrid)
{
    throw new Exception("Create a new straight grid failed.");
}

// Modify the name of the created grid
lineGrid.Name = "New Name1";
Copy VB.NET
' Create the geometry line which the grid locates
Dim start As New XYZ(0, 0, 0)
Dim [end] As New XYZ(30, 30, 0)
Dim geomLine As Line = Line.CreateBound(start, [end])

' Create a grid using the geometry line
Dim lineGrid As Grid = document.Create.NewGrid(geomLine)

If lineGrid Is Nothing Then
    Throw New Exception("Create a new straight grid failed.")
End If

' Modify the name of the created grid
lineGrid.Name = "New Name1"

See Also