ExportXml Method


Export this property set library to an external, XML-based file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012

Syntax

C#
public bool ExportXml(
	string fileName
)
Visual Basic
Public Function ExportXml ( _
	fileName As String _
) As Boolean
Visual C++
public:
bool ExportXml(
	String^ fileName
)

Parameters

fileName
Type: System String
Name of the file to write.

Return Value

True if the export succeeded, otherwise false.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL
Autodesk.Revit.Exceptions InvalidPathArgumentException The folder does not exist.

See Also