NewPointLoad Method (Reference, XYZ, XYZ, Boolean, PointLoadType, SketchPlane)


Creates a new hosted point load within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public PointLoad NewPointLoad(
	Reference reference,
	XYZ force,
	XYZ moment,
	bool isReaction,
	PointLoadType symbol,
	SketchPlane plane
)
Visual Basic
Public Function NewPointLoad ( _
	reference As Reference, _
	force As XYZ, _
	moment As XYZ, _
	isReaction As Boolean, _
	symbol As PointLoadType, _
	plane As SketchPlane _
) As PointLoad
Visual C++
public:
PointLoad^ NewPointLoad(
	Reference^ reference, 
	XYZ^ force, 
	XYZ^ moment, 
	bool isReaction, 
	PointLoadType^ symbol, 
	SketchPlane^ plane
)

Parameters

reference
Type: Autodesk.Revit.DB Reference
The Geometry reference to Beam's, Brace's, Column's, analytical line's end.
force
Type: Autodesk.Revit.DB XYZ
The 3d force.
moment
Type: Autodesk.Revit.DB XYZ
The 3d moment.
isReaction
Type: System Boolean
Specifies if the load is a reaction load. The load cannot be modified if isReaction=True.
symbol
Type: Autodesk.Revit.DB.Structure PointLoadType
The symbol of the PointLoad.
plane
Type: Autodesk.Revit.DB SketchPlane
Indicate the work plane of the PointLoad.

Return Value

If successful, NewPointLoad returns an object for the newly created PointLoad. a null reference ( Nothing in Visual Basic) is returned if the operation fails.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions InvalidOperationException If the product is not Revit Structure.

See Also