GetSimpleType Method


Gets the IFC type name.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013

Syntax

C#
public string GetSimpleType()
Visual Basic
Public Function GetSimpleType As String
Visual C++
public:
String^ GetSimpleType()

Return Value

The name.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions InvalidOperationException No type assigned or it is not a simple type.

See Also