SetName Method


Sets the name of the property set library.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012

Syntax

C#
public void SetName(
	string name
)
Visual Basic
Public Sub SetName ( _
	name As String _
)
Visual C++
public:
void SetName(
	String^ name
)

Parameters

name
Type: System String

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException name is an empty string. -or- name is not unique.
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL
Autodesk.Revit.Exceptions ObjectAccessException The property set library is read-only.

See Also