Constructs a new instance of ToggleButtonData, where the ToggleButton will execute an ExternalCommand when clicked.
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- name
- Type: System String
The internal name of the new button.
- text
- Type: System String
The user visible text seen on the new button.
- assemblyName
- Type: System String
The assembly path of the button.
- className
- Type: System String
The name of the class containing the implementation for the command.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | Thrown when a null reference ( Nothing in Visual Basic) is passed for one or more arguments. |
Autodesk.Revit.Exceptions ArgumentException | Thrown when an empty string is passed for one or more arguments. |