Sets new profile that defines the shape of the Fabric Sheet bending.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- bendProfile
- Type: Autodesk.Revit.DB CurveLoop
A profile that defines the bending shape of the fabric sheet. The profile can be provided without fillets (eg. for U shape, only three lines not three lines and two arcs), if so, then fillets (two arcs) will be automatically generated basing on the Bend Diameter parameter defined in the Fabric Wire system family. If the provided profile has no corners (has a tangent defined at each point except the ends), no fillets will be generated. The provided profile defines the center-curve of a wire.
Examples

private void ModifyBentFabricSheet(Document document, FabricSheet bentFabricSheet)
{
CurveLoop newBendingProfile = CurveLoop.CreateViaOffset(bentFabricSheet.GetBendProfile(), 0.5, new XYZ(0, 0, -1));
bentFabricSheet.SetBendProfile(newBendingProfile);
// Give the user some information
TaskDialog.Show("Revit", string.Format("Bent Fabric Sheet ID='{0}' modified successfully.", bentFabricSheet.Id.IntegerValue));
}

Private Sub ModifyBentFabricSheet(document As Document, bentFabricSheet As FabricSheet)
Dim newBendingProfile As CurveLoop = CurveLoop.CreateViaOffset(bentFabricSheet.GetBendProfile(), 0.5, New XYZ(0, 0, -1))
bentFabricSheet.SetBendProfile(newBendingProfile)
' Give the user some information
TaskDialog.Show("Revit", String.Format("Bent Fabric Sheet ID='{0}' modified successfully.", bentFabricSheet.Id.IntegerValue))
End Sub
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Thrown when bend profile contains an overlap or intersecting segments. -or- Thrown when bend profile is empty. -or- Thrown when bend profile contains an empty loop. -or- Thrown when bend profile contains multiple loops. -or- Thrown when bend profile contains a closed loop. -or- Thrown when bend profile contains arcs that are not distracted by a line. -or- Thrown when bend profile contains too short segments, so fillet can't be added. -or- Thrown when the provided profile cannot be used as a bending shape for this fabric sheet. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions DisabledDisciplineException | None of the following disciplines is enabled: Structural. |
Autodesk.Revit.Exceptions InvalidObjectException | The data-setting method is not applicable to fabric sheets that are flat. |