SetFoundationType Method


Sets an object that represents the type of the foundation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since: 2016

Syntax

C#
public void SetFoundationType(
	WallFoundationType type
)
Visual Basic
Public Sub SetFoundationType ( _
	type As WallFoundationType _
)
Visual C++
public:
void SetFoundationType(
	WallFoundationType^ type
)

Remarks

The Wall Foundation type can be used to access the multi layered structure of a foundation.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also