AllSegmentCurves Property


Retrieve the curves of all segments.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public CurveArray AllSegmentCurves { get; }
Visual Basic
Public ReadOnly Property AllSegmentCurves As CurveArray
	Get
Visual C++
public:
property CurveArray^ AllSegmentCurves {
	CurveArray^ get ();
}

Remarks

User can get these curves and then call the method AddSegment() or RemoveSegment() to add/remove specified segments. If the specified segment is already added/removed, nothing will happen.

See Also