Returns the total surface area of this solid.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Return Value
The real number equal to the total area of this solid.Remarks
Calculates the surface area by adding together the areas of faces comprising this solid. Will slightly underestimate if curved surfaces are present.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions InvalidOperationException | Thrown when this solid is not a valid Geometry object. |