Return a transform representing the relative position of any individual bar in the set.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- barPositionIndex
- Type: System Int32
An index between 0 and (NumberOfBarPositions-1).
Return Value
The position of a bar in the set relative to the first position.Remarks
The transform is a translation along the distribution path. It can be applied to the results of GetCenterlineCurves() to produce any bar in the rebar set. For barPositionIndex=0, the identity transform is always returned.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | barPositionIndex is not in the range [ 0, NumberOfBarPositions-1 ]. |