Checks whether a unit type is valid.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- unitType
- Type: Autodesk.Revit.DB UnitType
The unit type to check.
Return Value
True if the unit type is valid, false otherwise.Remarks
A unit type is considered valid if it is an actual unit type like UT_Length or UT_Angle. Obsolete values and the special values UT_Custom and UT_Undefined are not considered valid.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |