RuledFace Class


A ruled face of a 3d solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public class RuledFace : Face
Visual Basic
Public Class RuledFace _
	Inherits Face
Visual C++
public ref class RuledFace : public Face

Remarks

Ruled faces are defined by ruled surfaces bounded by edge loops. The surfaces provide natural UV parameterization to the faces.

Examples

Copy C#
private void GetRuledFaceInfo(Face face)
{
    RuledFace ruledFace = face as RuledFace;
    if (null != ruledFace)
    {
        Curve curve = ruledFace.get_Curve(0);
        XYZ point = ruledFace.get_Point(0);
    }
}
Copy VB.NET
Private Sub GetRuledFaceInfo(face As Face)
    Dim ruledFace As RuledFace = TryCast(face, RuledFace)
    If ruledFace IsNot Nothing Then
        Dim curve As Curve = ruledFace.Curve(0)
        Dim point As XYZ = ruledFace.Point(0)
    End If
End Sub

Inheritance Hierarchy

See Also