Indicates if parameters indicate if Rigid Links should be formed.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Field Value
For Structural Beams:- Enabled: rigid links will be formed, overriding Structural Column setting.
- Disabled: rigid links will not be formed, overriding Structural Column setting.
- FromColumn: rigid links may be formed, depending on Structural Column setting.
- Enabled: rigid links will be formed, unless Structural Beam setting overrides.
- Disabled: rigid links will not be formed, unless Structural Beam setting overrides.
Remarks
Rigid Links are the result of an interaction between neighboring Structural Columns and Structural Beams
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | When setting this property: rigidLinksOption is not valid for this Analytical Model. |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions InvalidOperationException | When setting this property: This AnalyticalModel does not support Rigid Links. |