Checks whether a PathType enum value will be valid to use with this ExternalFileReference.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- pathType
- Type: Autodesk.Revit.DB PathType
Remarks
- PathType.Server is only valid for ExternalFileReferences of type ExternalFileReferenceType.RevitLink
- PathType.Content is only valid for ExternalFileReferences of type ExternalFileReferenceType.KeynoteTable, ExternalFileReferenceType.AssemblyCodeTable and ExternalFileReferenceType.Decal
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |