Constructs an object that stores the basic size information for MEP duct, pipe, cable tray and conduit.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- nominalDiameter
- Type: System Double
Nominal diameter. The value should be a valid, positive Revit length.
- innerDiameter
- Type: System Double
Inner diameter. The value should be a valid, positive Revit length.
- outerDiameter
- Type: System Double
Outer diameter. The value should be a valid, positive Revit length.
- usedInSizeLists
- Type: System Boolean
Whether it is used in size lists.
- usedInSizing
- Type: System Boolean
Whether is used in sizing.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | The given value for nominalDiameter must be greater than 0 and no more than 30000 feet. -or- The given value for innerDiameter must be greater than 0 and no more than 30000 feet. -or- The given value for outerDiameter must be greater than 0 and no more than 30000 feet. |