Saves shared coordinates changes back to the linked document.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- callback
- Type: Autodesk.Revit.DB ISaveSharedCoordinatesCallback
A callback object to resolve situations when Revit encounters modified links.
Return Value
True if we saved the link or if there were no changes to save. False if the operation failed.Remarks
While this operation does not clear the document's undo history, you will not be able to undo this specific action, since it saves the link's shared coordinates changes to disk.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions InvalidOperationException | Revit could not save shared coordinates changes to the link or one of its nested links. |