Destroy Method


Delete the created analytical model and the analytical elements such as spaces, surfaces, and openings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since: 2012

Syntax

C#
[ObsoleteAttribute("This function is deprecated in Revit 2016. Use Document.Delete() on the EnergyAnalysisDetailModel instead to remove the model and all associated elements.")]
public static void Destroy(
	EnergyAnalysisDetailModel model
)
Visual Basic
<ObsoleteAttribute("This function is deprecated in Revit 2016. Use Document.Delete() on the EnergyAnalysisDetailModel instead to remove the model and all associated elements.")> _
Public Shared Sub Destroy ( _
	model As EnergyAnalysisDetailModel _
)
Visual C++
[ObsoleteAttribute(L"This function is deprecated in Revit 2016. Use Document.Delete() on the EnergyAnalysisDetailModel instead to remove the model and all associated elements.")]
public:
static void Destroy(
	EnergyAnalysisDetailModel^ model
)

Parameters

model
Type: Autodesk.Revit.DB.Analysis EnergyAnalysisDetailModel
The model will be destroyed.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also