Creates a new non-hosted line load within the project using data at point.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- aDoc
- Type: Autodesk.Revit.DB Document
Document to which new line load will be added.
- startPoint
- Type: Autodesk.Revit.DB XYZ
The start point of line load, measured in decimal feet.
- endPoint
- Type: Autodesk.Revit.DB XYZ
The end point of line load, measured in decimal feet.
- forceVector
- Type: Autodesk.Revit.DB XYZ
The applied 3d force vector.
- momentVector
- Type: Autodesk.Revit.DB XYZ
The applied 3d moment vector.
- symbol
- Type: Autodesk.Revit.DB.Structure LineLoadType
The symbol of the LineLoad. Set a null reference ( Nothing in Visual Basic) to use default type.
- plane
- Type: Autodesk.Revit.DB SketchPlane
The work plane of the LineLoad. Set a null reference ( Nothing in Visual Basic) to use default plane.
Return Value
If successful, returns the newly created LineLoad, a null reference ( Nothing in Visual Basic) otherwise.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Thrown when work plane is not valid. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentsInconsistentException | Thrown when all force and moment vectors are equal zero. |
Autodesk.Revit.Exceptions InvalidOperationException | Thrown if type could not be set for newly created line load. |